Register now    |   Login  

COMMUNITY





Back to Forum Index
   General Discussion
     Yamipod iTunes Version Compatibility
Register To Post
Poster Thread
Posted on: 2009/9/29 20:51

Yamipod iTunes Version Compatibility
At this writing Yamipod doesnt work with iTunes version 9. Latest Yamipod Version 1.8 is dated December 28, 2008 and is reported to work with iTunes ver 8.

Register To Post